Unable to add new bank account info when donating through the Church Center app

Incident Report for Planning Center

Resolved

A fix for this has been released for iOS and Android in version 2025.2.12. Please download that latest version to get the fix.
Posted Feb 12, 2025 - 16:57 PST

Identified

We are aware of an issue on the Church Center iOS and Android apps that users are unable to add new bank accounts when giving donations. We are working on a fix.
Posted Feb 12, 2025 - 15:17 PST
This incident affected: Church Center.