Apple Pay is temporarily disabled for donations
Incident Report for Planning Center
Resolved
The App Store has approved our release with the fix that restores Apple Pay functionality for Giving. Please check the App Store for an updated version, v2024.8.21.

Users on older versions with this bug who attempt to give will be prompted to update.
Posted Aug 21, 2024 - 19:20 PDT
Update
Getting approval from the App Store for this fix is taking longer than expected. We are doing everything we can to get it approved as soon as possible. As a reminder, giving via other payment methods, such as cards or bank accounts, and recurring donations are not affected.
Posted Aug 21, 2024 - 10:23 PDT
Update
We are still waiting on approval from the app store before re-enabling Apple Pay.
Posted Aug 20, 2024 - 14:31 PDT
Update
The issue has been resolved. We are just waiting on approval from the app store before re-enabling Apple Pay.
Posted Aug 19, 2024 - 15:22 PDT
Update
Unfortunately, it's looking like this issue will persist through the weekend. We are aiming to have a fix out on Monday.
Posted Aug 15, 2024 - 15:45 PDT
Identified
We've identified an issue with the Apple Pay button on Church Center and are working to resolve it as quickly as possible. Giving via other payment methods, such as cards or bank accounts, and recurring donations are unaffected.
Posted Aug 15, 2024 - 10:15 PDT
This incident affected: Giving.