Unable to create new signups or load registration data
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Aug 05, 2023 - 16:20 PDT
Investigating
There is an issue preventing new signups from being created, as well as existing registration data from loading. We are currently investigating the issue.
Posted Aug 05, 2023 - 15:19 PDT
This incident affected: Registrations.