Elevated Response Times
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Oct 20, 2020 - 15:49 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2020 - 13:05 PDT
Monitoring
The People app was experiencing very long load times for certain actions but a fix has been applied and our team is now monitoring the progress.
Posted Oct 20, 2020 - 12:35 PDT
This incident affected: People.