Services is experiencing a major outage of all pages.
Incident Report for Planning Center
Resolved
All pages in Services are fully back to normal.
Posted Sep 28, 2023 - 15:48 PDT
Monitoring
A fix has been implemented and we are monitoring the results. All pages should be fully operational.
Posted Sep 28, 2023 - 15:19 PDT
Investigating
We're currently experiencing a major outage with Services and are taking action to restore service as quickly as possible.
Posted Sep 28, 2023 - 15:16 PDT
This incident affected: Services.