Giving is experiencing slowness and lagged load times
Incident Report for Planning Center
Resolved
Giving batches and CSV exports are completing in a timely manner and tasks are being completed at expected speeds. Sorry about today's sluggishness. Thanks for your patience as we work on preventing this in the future.
Posted Apr 12, 2021 - 14:54 PDT
Monitoring
The backlog of tasks has now finished. Your committed Giving batches should be updated and your CSV exports should be delivered. We're now monitoring a fix which we put in place to prevent this from happening again.
Posted Apr 12, 2021 - 14:17 PDT
Update
The fix we've implemented is working and the system is working through a backlog of tasks. Your committed batches should be finished. Still working on delivering your CSV exports.
Posted Apr 12, 2021 - 13:17 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 12, 2021 - 11:33 PDT
Investigating
Giving is experiencing slowness and lagged load times due to high server traffic.
Posted Apr 12, 2021 - 10:10 PDT
This incident affected: Giving.