Services elevated latency
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Jul 08, 2024 - 17:06 PDT
Monitoring
Performance is back to normal, but we are continuing to monitor it.
Posted Jul 08, 2024 - 14:58 PDT
Investigating
Planning Center Services experienced a brief outage. It is back up and running now, but with elevated latency.
Posted Jul 08, 2024 - 14:01 PDT
This incident affected: Services.