Background checks are unavailable
Incident Report for Planning Center
Resolved
Initiating new background checks in People (and working with related lists and automations) seems to be working fine again as Checkr has come back online. We're sorry for this disruption in service today!
Posted May 18, 2022 - 14:19 PDT
Monitoring
It seems like Checkr is coming back to life. You may want to hold off ordering new background checks via People for a bit longer but things are looking better as their system recovers.
Posted May 18, 2022 - 12:03 PDT
Identified
New background checks can't be initiated as our provider Checkr is down. Bulk actions and automations in People will also be sluggish or non-responsive until they're back up. We'll report back as soon as we can.
Posted May 18, 2022 - 11:03 PDT
This incident affected: People.