Problems accessing Services Live on iOS

Incident Report for Planning Center

Resolved

A fix has been implemented and Services Live is back to full functionality, although you will need to refresh the page if you're seeing a 404 error. We’ll continue to monitor this fix to make sure all is well.
Posted Feb 16, 2025 - 10:18 PST

Investigating

We are currently investigating this issue.
Posted Feb 16, 2025 - 09:34 PST
This incident affected: Services.