Registrations updates in My Church Center are delayed
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted May 11, 2022 - 19:07 PDT
Monitoring
We've implemented a fix and Registration sign-ups are updating again in My Church Center. We'll continue to monitor the situation for a little while longer.
Posted May 11, 2022 - 18:35 PDT
Identified
We've identified the issue and we're working on a fix.
Posted May 11, 2022 - 16:04 PDT
This incident affected: Church Center.