Apple Pay on Giving temporarily disabled
Incident Report for Planning Center
Resolved
Apple Pay is reenabled for donations on Church Center. Donors using old app versions may be prompted to update, which should be quick and painless.
Posted Jul 01, 2024 - 16:08 PDT
Update
Apple Pay is still disabled for new donations while we wait for Apple to approve the bug fix we submitted yesterday. Note that previous donations and recurring donations established with Apple Pay are not affected. Sorry!
Posted Jun 30, 2024 - 09:25 PDT
Identified
Due to a bug affecting new donations made with Apple Pay, we've temporarily disabled Apple Pay. We anticipate re-enabling it tomorrow (Sat, June 29th) once Apple approves our fix. Sorry about this!
Posted Jun 28, 2024 - 15:26 PDT
This incident affected: Giving.