Elevated Response Times
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 12:31 PDT
Monitoring
Performance has recovered and we are continuing to monitor the situation.
Posted Sep 26, 2024 - 09:29 PDT
Investigating
One or more of our apps is loading very slowly or not at all for many customers. Our team is investigating.
Posted Sep 26, 2024 - 09:10 PDT