Giving Is Partially Down
Incident Report for Planning Center
Resolved
A fix is now in place and holding well. This incident is resolved.
Posted Mar 15, 2021 - 10:07 PDT
Monitoring
Giving should be snappy again. We're watching this closely and discussing what changes we can put in place this morning to ensure it stays that way.
Posted Mar 15, 2021 - 08:56 PDT
Identified
We've identified the issue and things are leveling out again. You should be able to work with batches, but you may consider holding off for a bit while we get a more permanent fix in place.
Posted Mar 15, 2021 - 08:44 PDT
Investigating
Giving, especially while working with batches, is super slow right now. We're investigating the cause.
Posted Mar 15, 2021 - 08:26 PDT
This incident affected: API and Giving.