Microsoft Outlook Email Deliverability Issues

Incident Report for Planning Center

Resolved

Microsoft has resolved their issue, and our delivery rates have returned to normal. Outgoing emails that had previously bounced during this incident have been successfully delivered.
Posted Jan 23, 2026 - 05:54 PST

Identified

We are currently experiencing email delivery issues to Outlook/Microsoft 365 addresses due to a temporary error on Microsoft's side. We are actively monitoring the situation and emails are being retried automatically and should be successfully sent once Microsoft fixes the issue. We'll post an update once services are restored to normal.
Posted Jan 22, 2026 - 12:38 PST