Planning Center is Very Slow or Unavailable
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted May 05, 2021 - 13:15 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 05, 2021 - 12:41 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 05, 2021 - 12:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 05, 2021 - 12:25 PDT
Investigating
We are currently investigating this issue.
Posted May 05, 2021 - 11:54 PDT
This incident affected: API, Check-Ins, Church Center, Giving, Groups, People, and Registrations.