People is failing to load for some users

Incident Report for Planning Center

Resolved

This incident has been resolved.
Posted Apr 26, 2021 - 18:08 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2021 - 16:41 PDT

Identified

The cause has been identified and addressed for some customers. We're still working towards full operation for everyone.
Posted Apr 26, 2021 - 16:33 PDT

Investigating

We're investigating an issue that is preventing some users from accessing People.
Posted Apr 26, 2021 - 15:23 PDT
This incident affected: People.