Slow response times
Incident Report for Planning Center
Resolved
Church Center, the API, and all products are still performing well. This incident is now resolved. Very sorry about this issue this morning!
Posted Mar 15, 2021 - 08:07 PDT
Monitoring
We've identified what caused the slowdown and issued a fix. All products and Church Center are back to full speed. We'll be monitoring things for a while just to be sure.
Posted Mar 15, 2021 - 07:50 PDT
Investigating
We are investigating slow response times across several applications.
Posted Mar 15, 2021 - 07:38 PDT
This incident affected: Accounts, API, Church Center, and People.