Church Center Mobile App church locator error.
Incident Report for Planning Center
Postmortem

On Sunday, June 7th From 7:34 am to 9:24 am PDT our Church Center mobile app on both iOS and Android displayed errors when opening the app which affected all users. This issue was caused by our rate-limiting grouping some API requests incorrectly. We applied a fix to correct the rate-limiting issue, and we have added additional monitoring around these limits to prevent this from occurring in the future. We’d like to apologize again for the disruption of the app on Sunday morning.

Posted Jun 11, 2020 - 13:24 PDT

Resolved
We're confident this issue is now resolved and the Church Center mobile app is fully back up and running. We're very sorry about this critical issue this morning! A full writeup will come next week.
Posted Jun 07, 2020 - 10:03 PDT
Monitoring
Okay, the fix for this issue appears to have solved the issue completely. We'll monitor things over the next few hours just to be sure.
Posted Jun 07, 2020 - 09:29 PDT
Identified
We think we've identified the issue and are testing the solution now to make sure.
Posted Jun 07, 2020 - 09:25 PDT
Investigating
The Church Center mobile app is showing a generic "Oops!" error message when trying to sign in or locate a church. All hands are on deck trying restore service as soon as possible.
Posted Jun 07, 2020 - 09:18 PDT
This incident affected: Check-Ins, Church Center, Giving, Groups, and Registrations.