Long load times in Calendar
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 17:59 PST
Monitoring
Calendar is back up to speed. We're monitoring our fix for a bit just to make sure.
Posted Nov 16, 2023 - 17:39 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 16, 2023 - 15:11 PST
Investigating
Calendar is moving very slowly right now and we're working to understand why.
Posted Nov 16, 2023 - 13:41 PST
This incident affected: Calendar.