Calendar is experiencing slow load times
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 13:07 PDT
Monitoring
The backlog that was causing degraded performance has been completed. We're continuing to monitor.
Posted Jul 24, 2024 - 13:27 PDT
Investigating
We are currently investigating this issue.
Posted Jul 24, 2024 - 11:55 PDT
This incident affected: Calendar.