Music Stand not loading songs properly for some android devices
Incident Report for Planning Center
Resolved
This issue has been resolved in Music Stand v4.5.12
Posted Dec 08, 2024 - 06:15 PST
Investigating
We are currently investigating this issue.
Posted Dec 08, 2024 - 05:59 PST
This incident affected: Services.