The admin side of Planning Center Giving is sluggish this morning (Church Center is fine).
Incident Report for Planning Center
Resolved
The issue is fully resolved and Giving has been operating at normal speeds for the past few hours. Again, sorry about the Monday morning sluggishness!
Posted Mar 06, 2023 - 14:12 PST
Monitoring
Planning Center Giving should be back to its normal speed now. We'll continue to keep an eye on it. Sorry for the slow performance this morning!
Posted Mar 06, 2023 - 09:48 PST
Identified
We've identified the cause and are looking into a remedy.
Posted Mar 06, 2023 - 09:20 PST
Investigating
We are currently investigating this issue.
Posted Mar 06, 2023 - 09:14 PST
This incident affected: Giving.