Login Issue on Church Center App for New Users

Incident Report for Planning Center

Resolved

We have resolved the issue affecting new account creation in the Church Center app. To receive the update, force close the app and reopen it — this may take a few attempts. You can confirm you have the latest version by checking your profile for v2026.5.6 Build#5792 Update f212.
Posted May 13, 2026 - 04:00 PDT

Identified

We've identified the root cause of the new account creation issue in the Church Center app and have a fix in progress. In the meantime, new customers can create their Church Center account without issue on Church Center web.
Posted May 12, 2026 - 18:56 PDT

Investigating

We are currently investigating an issue where new users are unable to add their first name during the initial login process on Church Center app. This may affect the ability to complete the setup of a new account on the latest version of the app (2026.5.6).
Posted May 12, 2026 - 17:25 PDT
This incident affected: Church Center.