Checkr is not processing background checks

Incident Report for Planning Center

Resolved

Checkr implemented a fix, and admins can request Checkr background checks again.
Posted Jul 31, 2025 - 16:58 PDT

Identified

Checkr's ability to request background checks is currently down, they're investigating the cause.
Posted Jul 31, 2025 - 15:10 PDT

Investigating

We are currently investigating this issue.
Posted Jul 31, 2025 - 14:40 PDT
This incident affected: People.