Services Mobile crashes on launch for users running iOS 17 and below

Incident Report for Planning Center

Resolved

The fix has been approved and shipped to the App Store in the form of a new version update, 6.8.2

This issuwchasxnow been resolved.
Posted Apr 15, 2026 - 18:14 PDT

Update

We are continuing to monitor the status of the App Store review with Apple. Once approved, this will available in a new App version update, 6.8.2
Posted Apr 15, 2026 - 15:52 PDT

Update

Update: Our fix is currently in App Store review with Apple. Once approved, this will available in a new App version update, 6.8.2
Posted Apr 15, 2026 - 12:49 PDT

Update

We have a fix in place, and have submitted to the App Store for expedited review. Once approved, this will available in a new App version update, 6.8.2
Posted Apr 15, 2026 - 09:23 PDT

Update

Our team is actively working on a fix for this issue affecting Services mobile app users on iOS 17 and below, and hope to have a patch submitted to the App Store with an expedited review soon.
Posted Apr 15, 2026 - 08:09 PDT

Identified

We've identified the cause of crashes affecting Services mobile app users on iOS 17 and below and are preparing a fix for App Store submission.
Posted Apr 15, 2026 - 06:40 PDT
This incident affected: Services.