People forms don't allow submissions if logged into Church Center
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 11:21 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 15, 2025 - 10:59 PST
Investigating
We are currently investigating this issue.
Posted Jan 15, 2025 - 10:22 PST
This incident affected: Church Center.