Button Visibility Issue in Giving

Incident Report for Planning Center

Resolved

This has been resolved. All buttons are visible again.
Posted Mar 18, 2026 - 06:58 PDT

Investigating

Customers may experience issues with certain buttons not being visible unless hovered over, such as "New Batch" or "Enter Pledge." Our team is working to resolve the issue promptly.
Posted Mar 18, 2026 - 06:37 PDT
This incident affected: Giving.