Church Center is showing "strayed off course" message for public pages
Incident Report for Planning Center
Resolved
A fix has been implemented, and this issue is now resolved.
Posted Mar 11, 2024 - 13:39 PDT
Investigating
We are aware of an issue affecting public pages on Church Center, which is causing them to display an error message. We are currently investigating the cause of this issue.
Posted Mar 11, 2024 - 13:26 PDT
This incident affected: Church Center.