Some event signups are unable to be completed

Incident Report for Planning Center

Resolved

This incident has been resolved and registering for events should be back to fully operational.
Posted May 10, 2026 - 13:13 PDT

Identified

Our team has identified the issue preventing some event registrations from being completed and are working on a fix.
Posted May 10, 2026 - 12:51 PDT

Investigating

Our team is aware of and looking into some reports of event registrations unable to be completed.
Posted May 10, 2026 - 12:49 PDT
This incident affected: Registrations.