Services mobile app crashing on launch for some users on iOS.

Incident Report for Planning Center

Resolved

This issue has been resolved. Affected users can update to version 6.4.3 in the App Store.
Posted Sep 03, 2025 - 17:14 PDT

Update

After successfully verifying the fix in beta, we’ve submitted the update to the App Store and are now awaiting review.
Posted Sep 03, 2025 - 14:00 PDT

Update

Our team has identified the issue and is implementing a fix for internal testing to ensure the fix resolves the issue.
Posted Sep 03, 2025 - 12:23 PDT

Identified

The issue has been identified and our team is working on a fix.
Posted Sep 03, 2025 - 11:38 PDT

Update

Our team is still actively investigating reports that the mobile app is crashing on launch for some iOS devices. We’ll share updates as soon as we know more.
Posted Sep 03, 2025 - 10:25 PDT

Investigating

Our team is currently investigating reports of the mobile app crashing on launch for some iOS devices.
Posted Sep 03, 2025 - 09:15 PDT
This incident affected: Services.