Church Center slowness
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 13:04 PST
Investigating
We are seeing slowness and the potential for errors on Church Center today due to an unexpected spike in traffic. We are working on blocking this traffic to improve performance.
Posted Jan 14, 2025 - 09:49 PST
This incident affected: Church Center.