Printing Issues on Services Mobile (iOS)

Incident Report for Planning Center

Update

Our team has submitted for an expedited review from the App Store for a fix that addresses an AirPrinting issue within Services mobile.

Once approved a new Services mobile version (iOS) will release to the App Store immediately and be available for download.
Posted Feb 14, 2026 - 21:12 PST

Update

Our team has implemented a fix for plan printing in the Services mobile app that is currently under App Store review.
Once approved it’ll be available in the app store for download.
Posted Feb 14, 2026 - 18:51 PST

Identified

We have identified the issue and are working on a fix via a new app version update.
Posted Feb 14, 2026 - 14:50 PST

Investigating

Users may experience difficulties printing from the Services mobile app as the AirPrint option is not showing the native print options as expected. We are currently investigating the issue.
Posted Feb 14, 2026 - 14:08 PST
This incident affects: Services.