Donation processing disruption

Incident Report for Planning Center

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 08:12 PDT

Update

We've deployed a fix and are seeing error rates drop. Donations should be processing successfully now, and we'll continue monitoring.
Posted Sep 02, 2026 - 07:39 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 07:37 PDT

Identified

Customers may experience issues when attempting to process donations. Our team has identified the cause and working on a resolution.
Posted Sep 02, 2026 - 07:34 PDT
This incident affected: Giving.