Church Center App not loading
Incident Report for Planning Center
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 11:29 PST
Monitoring
Church Center app is loading again; thank you for your patience.
Posted Jan 18, 2024 - 09:18 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 18, 2024 - 09:12 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 18, 2024 - 08:14 PST
Investigating
When launching Church Center App, the loading screen is shown but the app doesn't load. We're currently investigating this issue.
Posted Jan 18, 2024 - 06:45 PST
This incident affected: Church Center.