Issue adding new bank accounts
Incident Report for Planning Center
Resolved
This incident has been resolved!
Posted Nov 22, 2021 - 22:03 PST
Identified
The issue has been identified and we are working with Plaid on a fix.
Posted Nov 22, 2021 - 16:38 PST
Investigating
We are currently investigating an issue with adding new bank accounts for donors.
Posted Nov 22, 2021 - 16:21 PST
This incident affected: Giving.