Elevated Response Times
Incident Report for Planning Center
Resolved
People and Services are back up and fully operational.
Posted Aug 21, 2023 - 21:37 PDT
Monitoring
A fix is in place for the slowness with People and Services. Things should be back to normal. We are monitoring the fix.
Posted Aug 21, 2023 - 20:34 PDT
Identified
People and Services may still be slow. We have identified the problem and are working on a fix.
Posted Aug 21, 2023 - 20:06 PDT
Investigating
People and Services are loading very slowly or not at all for many customers. Our team is investigating.
Posted Aug 21, 2023 - 19:51 PDT
This incident affected: People and Services.