Giving is not accessible for some customers. Not all customers are impacted.

Incident Report for Planning Center

Resolved

We've restored access to all Giving customers. This incident has been resolved.
Posted Mar 13, 2025 - 17:00 PDT

Monitoring

A fix has been implemented. Access should be restored for everyone impacted. We are validating that everything is working as expected.
Posted Mar 13, 2025 - 16:05 PDT

Update

The issue has been resolved for almost half of the organizations impacted, and we are working on restoring access for the remaining.
Posted Mar 13, 2025 - 15:03 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2025 - 14:39 PDT

Investigating

Some customers are unable to access Giving in Church Center or Planning Center (admin). Donors are unable to give to those impacted. We are working to figure out the cause as quickly as possible. Not everyone is impacted.
Posted Mar 13, 2025 - 14:32 PDT
This incident affected: Church Center and Giving.