Elevated Response Times

Incident Report for Planning Center

Resolved

This incident has been resolved.
Posted Nov 26, 2023 - 13:39 PST

Monitoring

We have identified the issue and are currently monitoring the situation.
Posted Nov 26, 2023 - 11:26 PST

Update

We are still investigating the cause of the slow down in Services.
Posted Nov 26, 2023 - 10:19 PST

Update

We have the whole team continuing to investigate the issue.
Posted Nov 26, 2023 - 09:02 PST

Update

Services is loading again but is still running slowly. We are continuing to investigate.
Posted Nov 26, 2023 - 08:07 PST

Update

Services is not loading at all for customers. We are still investigating the issue.
Posted Nov 26, 2023 - 07:57 PST

Update

We are continuing to investigate this issue.
Posted Nov 26, 2023 - 07:48 PST

Investigating

Services is loading very slowly or not at all for some customers. Our team is investigating.
Posted Nov 26, 2023 - 07:17 PST
This incident affected: Services.