Planning Center is not available.
Incident Report for Planning Center
Postmortem

On Tuesday, December 7, 2021, we took all Planning Center applications offline in response to a multi-service outage in Amazon Web Services (AWS) Northern Virginia region.

We know this outage caused a big disruption to your day and we don't take bringing down any of our products lightly, let alone the entire suite. We want to provide you with more context about what happened and why.

When you connect to a Planning Center product from your computer, phone, or tablet, you're connecting to our systems in AWS data centers in Northern Virginia. Our products span multiple data centers within that area to ensure that issues in a single data center do not cause a service disruption. Unfortunately, AWS issues last Tuesday were region-wide and lasted several hours, which disrupted all of our data centers.

We use AWS's Simple Notification Service (SNS) as the plumbing for internal messaging between products and send hundreds of requests per second to the service. At around 7:30 AM Pacific, over 90% of our requests to SNS began to fail. When an event was updated in Registrations, Check-Ins wasn't getting the memo. When events were made in Registrations and Groups, Calendar had no idea about the party. This caused concern for data consistency issues where one product would never receive data from the other, so at 8:15 AM Pacific, we took all products offline.

After going offline, our inability to interact with AWS services in the region extended to several other services that we rely on and despite our persistent attempts, we weren't able to bring our applications back online until 3:15pm Pacific, followed by a full recovery at 5:00pm Pacific when all data was verified to be back in sync.

Know that we'll do everything we can to learn from this, improve our resiliency, and continue building reliable and highly-available products.

Posted Dec 15, 2021 - 12:05 PST

Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 19:19 PST
Update
Products are operational but we’re still working through the backlog that was created during the outage. We’re getting close!
Posted Dec 07, 2021 - 18:12 PST
Update
Planning Center is back up! Features with real-time updates aren't back yet, we're working on restoring that functionality.
Posted Dec 07, 2021 - 15:21 PST
Monitoring
Planning Center is back up! Features with real-time updates aren't back yet, we're working on restoring that functionality.
Posted Dec 07, 2021 - 15:14 PST
Update
Still waiting for the Amazon outage to be resolved. In the meantime, we're working to make sure there will be minimal downtime once the servers are back online.
Posted Dec 07, 2021 - 14:02 PST
Update
We are working to get Planning Center back up with only some functionality missing. We continue to wait for Amazon so we can restore full functionality.
Posted Dec 07, 2021 - 12:37 PST
Update
We are still waiting on Amazon to restore service.
Posted Dec 07, 2021 - 11:42 PST
Update
We are still waiting on Amazon to restore service.
Posted Dec 07, 2021 - 11:03 PST
Identified
Amazon has identified the cause of this issue. We are still waiting on an ETA from them for full recovery.
Posted Dec 07, 2021 - 10:27 PST
Update
We are still waiting on a restoration of service from our hosting provider. We are working to make sure we can restore functionality as soon as possible.
Posted Dec 07, 2021 - 09:43 PST
Update
All products are currently unavailable as we continue to wait for third-party services to come back online.
Posted Dec 07, 2021 - 08:39 PST
Investigating
A third-party service is down, causing intermittent errors throughout all our products.
Posted Dec 07, 2021 - 07:50 PST
This incident affected: Accounts, API, Calendar, Check-Ins, Church Center, Giving, Groups, Login, People, Services, and Registrations.